Anforderungen

Für den erfolgreichen Einsatz von Kwave brauchen Sie:

  • einen Computer mit installiertem Linux (Kwave läuft möglicherweise auch unter anderen Betriebssystemen, aber dieses haben wir nicht getestet. Bitte lassen Sie es uns wissen, wenn Sie es auf anderen Plattformen/ Betriebssystemen zum laufen gebracht haben)

  • eine funktionierende Soundwiedergabe (nicht wirklich erforderlich für die Benutzung, aber was sollte man mit einem Soundeditor, wenn man sich nicht die Ergebnisse anhören kann?)

  • KDE-4.5 oder höher (zumindest die Bibliotheken: Kwave läuft auch unter gnome, wenn die richtigen Bibliotheken installiert sind).

  • qt-4.5.0 oder neuer (kommt normalerweise bei der Installation von KDE4 mit)

  • ALSA 1.0.14 oder höher (für Aufnahme/Wiedergabe)

  • id3lib-3.8.1 oder neuer (für ID3-Tags)

  • mad-0.15 oder neuer (optional für MP3-Import/Export)

  • flac-1.1.0 oder neuer (für FLAC-Import/Export)

  • libsamplerate-0.1.3 oder neuer (Abtastraten-Änderung)

Für eine aktuellere und vollständigere Liste lesen Sie bitte die README-Datei, die in der Quellcode-Distribution enthalten ist. Diese Datei enthält auch einige Tipps um Kwave unter anderen Distributionen zum Laufen zu bekommen oder zu kompilieren.

Wenn Sie vorhaben, Kwave aus den Quellen zu kompilieren, brauchen Sie zusätzlich mindestens:

  • cmake-2.4.6 oder neuer

  • Einen aktuellen C/C++ Compiler. GCC-4.x sollte funktionieren, einige ältere und jede neuere Versionen (beispielsweise gcc-4.8 und neuer) sollten ebenfalls funktionieren.

  • Die glibc2 (libc-6) Entwicklungsumgebung. Auf SuSE-Systemen heisst das Paket "libc", auf anderen Systemen könnte es "libc-devel" heissen.

  • Die KDE4-Entwicklungsumgebung: "kdelibs4-devel", "kdemultimedia4-devel", "kdesdk4".

  • Die Qt4-Entwicklungsumgebung, das Paket heisst normalerweise "qt4-devel" oder ähnlich.

  • Pulseaudio 0.9.16 oder neuer

  • id3lib-devel-3.8.1 oder neuer

  • fftw-3.0 oder neuer

  • mad-devel-0.15 oder neuer (falls Sie die Erlaubnis haben MP3-Code zu verwenden)

  • flac-devel-1.1.0 oder neuer

  • Falls Sie beabsichtigen Kwave über GIT zu beziehen, brauchen Sie auch ein aktuelles git-Paket.

  • ...einige andere Pakete, bitte lesen Sie hierzu die Datei "README", die im Quellpaket enthalten ist.