Ce dont vous avez besoin.

Dans l'ordre, pour pouvoir utiliser Kwave, vous avez besoin :

  • D'un ordinateur sous LINUX (Kwave peut théoriquement fonctionner sous d'autre système d'exploitation, mais nous n'avons jamais testé cette possibilité. nous vous remercions de nous avertir si vous avez réussi à faire fonctionner le logiciel sur une autre plate-forme).

  • D'un équipement audio pour l'écoute des fichiers sonores (ce n'est pas absolument nécessaire, mais que faire avec un éditeur de pistes audio sans pouvoir écouter le résultat de son travail).

  • De KDE-3.1 ou supérieur (ou au moins les bibliothèques appropriées. Si vous êtes un fan de l'environnement de bureau Gnome, vous pouvez également utilisé Kwave à partir du moment que les librairies de KDE sont installées.).

  • De Qt-4.1 ou supérieure (normalement associée avec KDE4).

  • ALSA 1.0.14 or higher (for record/playback)

  • PulseAudio 4.0 or higher (for record/playback)

  • De la bibliothèque « id3lib-3.8.1 » ou supérieure

  • De la bibliothèque « mad-0.15 » ou supérieure

  • De la bibliothèque « id3lib-3.8.1 » ou supérieure

  • la bibliothèque « samplerate-0.1.3 » ou supérieure

Pour un liste plus complète de mise à jour, consultez le fichier README inclut dans les sources du programme. Il peut être également trouvé à cette URL : http://sourceforge.net/p/kwave/code/ci/HEAD/tree/README

Si vous désirez compiler Kwave à partir des sources, vous avez besoin:

  • cmake-2.4.6 or newer

  • D'un compilateur C/C++comme GCC-2.95.3. Cela fonctionne correctement avec certaines anciennes versions ainsi que les nouvelles versions comme GCC-3.2.

  • De la bibliothèque de développement glibc2 (libc-6). Sur la distribution SuSE Linux, le paquetage se nomme « libc ». Sur d'autres systèmes il peut s'appeler « libc-devel ».

  • De l'environnement de développement de KDE3 : « kdelibs3-devel », « kdemultimedia3-devel », et « kdesdk3 ».

  • De l'environnement de développement Qt. Le paquetage se nomme normalement « qt3-devel » ou quelque chose de similaire.

  • pulseaudio-4.0 or newer

  • la bibliothèque « id3lib-3.8.1 » ou supérieure

  • fftw-3.0 or newer

  • mad-devel-0.15 or newer (if you have the permission to use MP3 code)

  • la bibliothèque « mad-0.15 » ou supérieure

  • Si vous désirez utiliser GIT, il vous faut aussi la version actuelle du paquetage correspondant à GIT.

  • ...d'autres paquetages logiciels. Pour plus d'informations, veuillez consultez le fichier "README" qui est inclut dans les sources du programme.