Requisitos

Con el fin de usar Kwave exitosamente, necesita:

  • un ordenador ejecutando Linux (Kwave podría funcionar en otros sistemas operativos, pero nunca hemos lo hemos probado, por favor, avísenos si lo hace funcionar en otra plataforma o sistema operativo)

  • un dispositivo reproductor de sonido (realmente no es necesario para usar el programa pero ¿para qué querría un editor de sonido si no puede escuchar el resultado de su trabajo?)

  • KDE-4.5 o superior (por lo menos las bibliotecas; si es un usuario de gnome también puede utilizar Kwave si instala las bibliotecas adecuadas).

  • Qt-4.7 o superior (normalmente se incluyen con KDE4)

  • ALSA 1.0.14 o superior (para grabación/reproducción)

  • PulseAudio 4.0 o superior (para grabación/reproducción)

  • id3lib-3.8.1 o superior (para metadatos ID3)

  • mad-0.15 o superior (opcionalmente para importación/exportación MP3)

  • flac-1.2.0 o superior (para importación/exportación FLAC)

  • libsamplerate-0.1.3 o superior (conversión de frecuencia de muestreo)

Para una lista más completa y actualizada, por favor, consulte el archivo 'README' que se incluye con el código fuente. Este archivo contiene algunos consejos para hacer funcionar Kwave en ciertas distribuciones.

Si planea compilar Kwave desde las fuentes necesitará al menos:

  • cmake-2.4.6 o superior

  • Un compilador reciente de C/C++. GCC-4.x funciona correctamente, algunas versiones antiguas y cualquiera más nueva (como gcc-4.8 o superior) pueden funcionar también.

  • El entorno de desarrollo glibc2 (libc-6). En SuSE el paquete tiene por nombre "libc", en otros sistemas puede tener por nombre "libc-devel".

  • El entorno de desarrolo KDE4: "kdelibs4-devel", "kdemultimedia4-devel", "kdesdk4".

  • El entorno de desarrollo Qt4, el paquete normalmente tiene por nombre "qt4-devel" o similar.

  • pulseaudio-4.0 o superior

  • id3lib-devel-3.8.1 o superior

  • fftw-3.0 o superior

  • mad-dvel-0.15 o superior (si tiene permiso para utilizar el codifcador MP3)

  • flac-devel-1.2.0 o superior

  • Si su intencio es obtener Kwave mediante GIT también necesitará un paquete git actual.

  • ...muchos otros paquetes, por favor eche un vistazo al archivo 'README' incluido en el paquete fuente.