Požadavky

Abyste program mohl úspěšně používat Kwave, potřebujete:

  • počítač, na němž běží Linux (Kwave může být spouštěn i pod některými dalšími operačními systémy, ale nikdy jsme tuto možnost nezkoušeli. Dejte nám, prosím, vědět, jestliže se vám podaří spustit Kwave na jiné platformě/pod jiným operačním systémem)

  • Pracující přehrávání zvuku (pro použití programu není ve skutečnosti vyžadováno, ale co byste asi tak dělal s editorem zvuku, kdybyste si nemohl poslechnout výsledek vaší práce?)

  • KDE ve verzi 4.5 nebo vyšší (alespoň knihovny. V případě, že jste fonouškem prostředí GNOME, můžete program spouštět také,Kwave pokud jsou nainstalovány ty správné knihovny).

  • qt ve verzi 4.5.0 nebo vyšší (normálně je k dispozici s KDE4)

  • ALSA ve verzi 1.0.14 nebo vyšší (kvůli nahrávání a přehrávání)

  • id3lib ve verzi 1.0.14 nebo vyšší (kvůli ID3 značkám)

  • mad ve verzi 0.15 nebo vyšší (volitelně kvůli zavedení/vyvedení MP3)

  • flac ve verzi 1.1.0 nebo vyšší (kvůli importu FLAC)

  • libsamplerate-0.1.3 nebo vyšší (převod kmitočtu)

Kvůli úplnějšímu a nejnovějšímu seznamu požadavků se, prosím, poraďte se souborem README. který je zahrnut ve zdrojové distribuci, nebo jej lze najít zde: http://sourceforge.net/p/kwave/code/ci/HEAD/tree/README. Tento soubor obsahuje také některé zvláštní tipy, jak program Kwave pod některými distribucemi Kwave spustit a/nebo sestavit.

Pokud máte v úmyslu kompilovat program Kwave ze zdrojových souborů, budete alespoň potřebovat:

  • cmake-2.4.6 nebo novější

  • Nedávný překladač C/C++. GCC-4.x pracuje dobře, některé starší a některé novější verze (jako gcc-4.8 a novější) pracují rovněž.

  • Vývojové prostředí glibc2 (libc-6). Na systémech se SUSE se tento balíček nazývá "libc", na jiných systémech může být nazván "libc-devel".

  • KDE4 vývojové prostředí: "kdelibs4-devel", "kdemultimedia4-devel", "kdesdk4".

  • Qt4 vývojové prostředí, balíček se obyčejně nazývá "qt4-devel" nebo podobně.

  • pulseaudio-0.9.16 nebo vyšší

  • id3lib-devel-3.8.1 nebo vyšší

  • fftw-3.0 nebo vyšší

  • mad-devel-0.15 nebo vyšší (pokud máte oprávnění používat kód MP3)

  • flac-devel-1.1.0 nebo vyšší

  • Pokud máte v úmyslu získat Kwave zdrojové soubory prostřednictvím Git, budete také potřebovat aktuální balíček "Git".

  • ...a mnoho dalších balíčků. Podívejte se, prosím, na "README" soubor je zahrnut ve zdrojovém balíčku.